Clients are disconnected from session

Incident Report for Interprefy AG

Postmortem

Summary

On September 10th 10:48AM CET, we have received information from clients that users were logged out from the meetings.

We are sorry that we caused this incident and for the impact it had on your meetings.

We scheduled a maintenance window to update a ping token used between our web client and statistic module. Due to a script error the statistic module token was not appended with the new token but overwritten. After the change was deployed, the statistic module did not recognize the clients and triggered the log out on client side.

To resume the meetings, the clients needed to re-login to Interprefy platform.

Causes

Statistic module token was not modified in the correct way which caused the web clients to log off.

Affected Clients

Meetings that were running at the same time as the token change were affected. Users needed to re-login to the platform to continue the meeting.

Preventive Actions

We have changed the script to update the ping token to always append a new token and not overwrite the existing one. This ensures this situation will not occur further.

Posted Sep 10, 2020 - 15:18 UTC

Resolved

Analysis in progress.
Clients resumed meetings and all systems are available.
Posted Sep 10, 2020 - 08:48 UTC